This project has moved and is read-only. For the latest updates, please go here.

Doesn't support file locations with spaces

Sep 6, 2009 at 9:11 AM

Hi,

I arrange my development projects in folders with spaces in them. Browser Chooser does not pass the file locations to the browsers properly in this case.

Is there a workaround to this (apart from renaming all my directories)?

 

Thanks for this time-saving application!

Lyon

Sep 6, 2009 at 8:55 PM

Can you give me an example of the url you're trying to open that fails? I had though spaces in the url worked but I guess I'm wrong. If you give me an example then I can test.

Thanks

Sep 7, 2009 at 9:01 AM

Hi,

An example would be:

file:///C:/Documents%20and%20Settings/User/My%20Documents/Folder%20Name/index.html

where there are spaces in the folder names.

Thanks for looking into this issue :).

Sep 8, 2009 at 3:26 AM

I have not been able to reproduce that. I was able to open this type of file without any problems: E:\temp\Rally 2 Backup\Documents\VB.Net Projects\test.html

Perhaps the changes I made for Beta 1 resolved the issue. Once Beta 1 is released, if you could try again and report back if it's solved or still an issue, that'd be great.

Beta 1 should be out in a day or two, just have a minor fix to make.

Sep 10, 2009 at 6:09 PM

Hi,

I downloaded the latest Beta Portable and the same problem remains.

It's easier for me now that I can enter the url that Browser Chooser is opening.

This works: C:\Users\username\Documents\Projects\projectname\index.htm

This doesn't work: C:\Users\username\Documents\Projects\project name\index.htm. Browser choose attempts to open this address instead: name\index.htm

 

Hope that helps!

Thanks for looking into this bug :)

 

Sep 10, 2009 at 7:40 PM

Weird.... what system are you running it on? I can't reproduce that, can anyone else?

I just opened a file from c:\users\username\desktop\test name\test.htm and it opened it perfectly fine. It changed "test name" to "testn~1" or something like that in the url and worked great.

Perhaps someone else can reproduce and look into this in the source, because it seems to me like it should work :|

Sorry

Sep 11, 2009 at 12:23 AM
Edited Sep 11, 2009 at 12:23 AM

I just double clicked on C:\Users\Danny\Documents\System Summary - SUE-PC.htm and Browser Chooser opened it as C:/Users/Danny/DOCUME~1/SYSTEM~1.HTM, so it's fine on my end. I also added a space in the folder path and it worked fine then too.

Edit: I'm running Windows 7, what are you using?

Sep 11, 2009 at 4:38 AM

This is so strange.

I'm running Vista Home Premium.

I tried C:/Users/name/Documents/project name/project/index.htm and Browser Chooser will open as name/project/index.htm

Does anyone have the same problem as me?

Sep 11, 2009 at 5:30 AM
Edited Sep 11, 2009 at 5:31 AM

Update:

I managed to get Browser Chooser working on my Windows XP (netbook) and other Vista Home Premium (desktop). But it doesn't work on this laptop running Vista Home Premium. Strange!

I did have trouble setting Browser Chooser as the default browser on my desktop's Vista Home Premium though. Normally I'll right-click and Run as administrator to get it to work, but alas, it didn't for this pc. I had to go Default Programs to set it manually.

Sep 11, 2009 at 4:11 PM

You should check what versions of .NET each computer is running, and try installing it again on the laptop. It could be something wrong with that.

Also, I have UAC off, so that could be worth a try too.