Slow to start...

Sep 11, 2009 at 6:29 PM
Edited Sep 11, 2009 at 6:35 PM

This is a great app, and I have been looking for something like this for a while.

But one wish I have is that it would start up faster. I don't mean to look a gift horse in the mouth, and will absolutely use and appreciate this app as is. But, that said, the experience of using it would be greatly improved if it were faster. Right now it takes about 10 seconds for me to see the Browser Chooser window.

One idea that crossed my mind is if Browser Chooser were constantly running as an app in the system tray, it wouldn't have to "start up" every time. When a link is clicked, it would display the same dialog as it does now, but maybe it would spring up faster. I understand this idea may not work at all with how it's been developed so far... just throwing it out there.

 

Thanks again,

Daniel

 

edit- System info, which would be useful:  Running Vista SP2 32 bit on an Intel Core 2 6600 (2.4 GHz) with 4 GB of RAM.

Sep 11, 2009 at 8:37 PM
Edited Sep 11, 2009 at 8:37 PM

That's weird, I'm running it on an Intel Core 2 Duo 2GHz 3GB RAM system (Windows 7 32bit) with no problems. The tray icon would be cool for people having a problem, but I'd prefer if it was an option rather than the only behaviour. It would have to be modified to only have one instance open at a time and to be able to be passed URLs during runtime rather than on opening.

Edit: I may give this a shot if Jan or anybody else doesn't.

Sep 12, 2009 at 9:18 PM

I have a system that is Windows 7 RTM 64Bit (Enterprise 90 day trial) and it takes 13 seconds to launch the program directly (Version 1.0.4.13406)

I then tried turning off the Auto check for updates and it launches immediately.

Coordinator
Sep 14, 2009 at 1:33 AM

I'm not a fan of the tray icon at all, so if someone were to build it, it would definitely have to be optional.

Yes, the autocheck could cause slowdowns if the website that is being checked for the version number is unreachable or slow to connect to for you. I haven't had that experience myself but it looks like turning off autocheck is a valid workaround.

 

Coordinator
Sep 14, 2009 at 1:35 AM

There is also an entry in the issue tracker to make the autocheck happen in the background so it won't cause any slowdowns. Issue is 2415 and once that is solved, it'll solve your problem :)

 

Sep 14, 2009 at 9:12 PM

Unchecking the "Check for Updates" checkbox (check checkerstein) looks to have solved the issue! Check plus for you.

Check.

Thanks,
Moskie

 

 

Developer
Sep 14, 2009 at 9:13 PM

I actually fixed this by only scheduling an auto-update check ever 3 days.

Doing the update check on a background thread won't work since it's likley to complete after the user has selected a browser. Especially true for when you are bypassing the selection screen for a specific URL.

Sep 3, 2011 at 6:46 PM

I unchecked the auto update check and its still slow, 

my opinion, have a set of skins and looks, to change from visual effects and aero stuff to a more basic look

my note is old but its good, the only problem is the crappy video board, and eveything that look "aero" or aerolike is slow to open

 

tks